• Welcome, Guest. Please login.
 
July 07, 2020, 04:06:08 am

News:

Welcome to the SQLitening support forums!


Work In Local Mode but not Server Mode

Started by Marty Francom, October 29, 2013, 02:37:44 pm

Previous topic - Next topic

Marty Francom

I wrote a simple program and it works perfectly in "Local Mode"  but
when I run it in "Server Mode" the database opens OK  but when the
program searches for a record I get the error message:

        1 = no such table; Prescribers

Here's the INI setup for remote mode:

[Settings]

DBname=WenoPrescribers.db3
DBpath=\RSI Easy Script\WexPrescribers
;IP= (your servers IP address or the Computer's name)
IP=MartinASUS
Port=51234

Any ideas what might be the problem?

cj

October 29, 2013, 09:07:56 pm #1 Last Edit: October 30, 2013, 12:31:13 am by cj
The general section of SQLiteningServer.Inc  doesn't look right.
Also, I can only get to work with Hosts = a numbered address.
Correction  SQLiteningServer.Cfg  (corrected by Marty, below)
[General]
ServiceNameSuffix=
Port = 51234
Hosts = 192.168.1.2
LogConnDcon=Yes
LogInvalidInMessage=Yes
CreateDatabaseAllowed=Yes
TrimLogManually=No
MaxChunkSize=
MaxConnections=10
ConnectionTimeOut=-1

Marty Francom

The above is my programs INI.   SQLiteningServer uses a  .cfg file. 
Here's my SQLiteningServer.cfg

[General]
ServiceNameSuffix=
Port=51234
Hosts=ASUSdesktop
LogConnDcon=Yes
LogInvalidInMessage=Yes
CreateDatabaseAllowed=No
TrimLogManually=No
MaxChunkSize=
ConnectionTimeOut= -1

Like the server is setup correctly and works fine with other programs.   
I think long file names are causing the problem.  Because when I moved the
program to just a directory just off the C drive it then worked.

cj

October 29, 2013, 11:27:44 pm #3 Last Edit: October 30, 2013, 12:30:48 am by cj
This worked, but see the notes below.
"c:\long folder name\bin\sqliteningserver.exe"
"c:\long folder name\bin\This is a long folder\long database name.db3"
slconnect $IpAddress,%Port
slOpen "This is a long folder\long database name.db3","C"

1) Used XCOPY to the long folder above after uninstalling the service.
2) The first time the service started there was no error, but clients could not connect.
3) Stopped the service and restarted and got messagebox about incorrect paths.
4) Tried restarting service again and no errors and client connected.


cj

The connections to the server quit working.
Turned off firewall on server and they started working again.
Deleted SqliteningServer.exe from allowed programs in firewall.
Added SqliteningServer.exe to allowed programs in firewall.
Everything is working again.


Rolf Brandt

Hi Marty,

Quote
Here's the INI setup for remote mode:

[Settings]
DBname=WenoPrescribers.db3
DBpath=\RSI Easy Script\WexPrescribers
;IP= (your servers IP address or the Computer's name)
IP=MartinASUS
Port=51234


The problem is in this line:
DBpath=\RSI Easy Script\WexPrescribers

it rather should be:
DBpath=RSI Easy Script\WexPrescribers

No slash is needed in remote mode, The FileName is assumed to be relative to the folder which the service is running from.
(See helpfile under slOpen)

Rolf

I like to cook with wine - sometimes I even add it to the food.
www.rbsoft.eu

cj

Good news!
I learned moving the server may require changing the firewall and long file names work.
Never used long file names.